Jump to content


What will kill the game.

Optimization requirements GPU CPU DX9 Warplanes Computer System Coffin End of game

  • Please log in to reply
8 replies to this topic

weekend_pilot #1 Posted 26 November 2016 - 03:14 PM

    Airman Basic

  • Member
  • 552 battles
  • 3
  • Member since:
    07-18-2013

Good day to all.

 

I do play the game since beta. I read a lot of discussions. Rarely participate.

It is not gameplay balance what will kill the game - this part is ok.

 

Lack of optimisations at all is a nail to your coffin !!! 

 

My PC isn't a beast, I have never expected a lot from it.

But I have tested the game in computer retailer showroom on £3000+ rig and it behaves the same.

What  a shame for a developer must be  if third fastest i7 processor with fastest graphics card on the market can't run game properly.

It is drops to 40-45fps, changing any settings makes no difference. Even Gsync monitor helps only a little. Wake.

For god sake. It is end of 2016 !!! 

Era of ultra, 144hz gaming, multi core, multi thread and fibre optic. This project stucked on some single thread ancient DX9 architecture.

Been a big fan of WoWP but  I am stopping to pay any money for hangars cuz soon I will need 6GHz CPU to play at least 50fps.

 

If developers not do anything to bring the game technologically to XXI century, their servers will run exclusively on bots.

By the way, it is going on already during certain parts of the day.

 

For a gamer this game is discarded as unplayable due to performance issues as for today.

Thank you.



Alrion1704 #2 Posted 26 November 2016 - 07:56 PM

    Second Lieutenant

  • Conquest Member
  • 36 battles
  • 1,082
  • Member since:
    03-14-2012

a dirend did upgarade his system to i7 6700k (+ new board & ram) and with the "old" gtx 660 over 60 fps.

so would say the 3000 pounds rig is absolute crap

i play myself on a i5 750 with a gtx760 and have drops down to 20 fps


Edited by Alrion1704, 26 November 2016 - 08:05 PM.

Spoiler

 


Cheaterhater #3 Posted 26 November 2016 - 08:07 PM

    Testpilot

  • Squadron Leader
  • 0 battles
  • 1,950
  • [JFA] JFA
  • Member since:
    08-19-2012

View PostAlrion1704, on 26 November 2016 - 08:56 PM, said:

a dirend did upgarade his system to i7 6700k (+ new board & ram) and with the "old" gtx 660 over 60 fps.

so would say the 3000 pounds rig is absolute crap

i play myself on a i5 750 with a gtx760 and have drops down to 20 fps

 

I'd rather take the safe choice and say that the engine is absolute crap. And this thread just proves what I've been saying for years now. The engine is so terrible that the game is losing players not because of the gameplay, but because of the fact that they can't even run the game properly.
RIP WoWP

DeckardIRL #4 Posted 26 November 2016 - 08:40 PM

    Senior Master Sergeant

  • Advanced Member
  • 90 battles
  • 101
  • Member since:
    06-23-2014
retailer showroom= shite internet connection.....

Alrion1704 #5 Posted 26 November 2016 - 10:18 PM

    Second Lieutenant

  • Conquest Member
  • 36 battles
  • 1,082
  • Member since:
    03-14-2012

i didnt deny that the engine is crap,

what i did say is the 3000 pound pc is crap.

and the 6500k did cost around 300€ the mainboard 150€ and the ram i belive 120€ = allways 60fps

 


Spoiler

 


weekend_pilot #6 Posted 27 November 2016 - 03:23 AM

    Airman Basic

  • Member
  • 552 battles
  • 3
  • Member since:
    07-18-2013


Thanks for your comments.

Post was impulsive.
My pc is old Phenom X6 16RAM GTX 1060.
WoWP runs at 35-60fps.45fps most of the time.
 
so planing to upgrade:
 
At showroom. i7 6800k, 64RAM, GTX 1080
WoWP runs at 45-100fps, 60fps+ most of the time.
 
My conclusion:
Game hasn't utilized 300% more capable CPU so no point to throw money at.
My 6 yo AMD plays any other game in 80 -120fps (with few exceptions ofc).
 

View PostDeckardIRL, on 26 November 2016 - 08:40 PM, said:

retailer showroom= shite internet connection.....

Fibre optic, HD client downloaded in seconds, ping to die for.

I suspected my place connection crap but seems not to be the issue here.

 

I wonder what CPU does WoWP need for 144hz gaming?

Bye bye to upgrade for now.

I hope devs do something.

 

Good hunting!

 

 

 



omglaserspewpew #7 Posted 27 November 2016 - 10:52 AM

    Second Lieutenant

  • Advanced Member
  • 2097 battles
  • 1,184
  • Member since:
    01-26-2012
I don't think the quality of internet connection plays a major part in lag and rubber-banding. I tried playing the game on many different connections, wired, wireless, cable, optical, ADSL, and even with some puny cable and wi-fi connection with torrents running behind it performed rather well.

CheefCoach #8 Posted 03 December 2016 - 11:30 PM

    Second Lieutenant

  • Conquest Member
  • 6242 battles
  • 1,151
  • [BBMM] BBMM
  • Member since:
    01-26-2012
Try to upgrade your graphic card drivers. It worked for me. 
https://stats-sig.eu/wowp/CheefCoach/ussr/xs/en/sig.png

_Desper #9 Posted 04 December 2016 - 04:23 PM

    Second Lieutenant

  • Beta Tester
  • 1795 battles
  • 1,151
  • Member since:
    01-26-2012
I have to say that WoWP never was so badly optimized as it is now. I have I7 @2.9, GTX 750, 12 GB ram and I can barely play on very low. Worst is Bay map, FPS arround 30 or lower. Some maps never drops under 55 fps.





1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users