Jump to content


x3 Bonus bug?


  • Please log in to reply
9 replies to this topic

__KDR__ #1 Posted 12 January 2018 - 06:31 PM

    Senior Airman

  • Member
  • 632 battles
  • 15
  • Member since:
    07-18-2013
Hello everyone !!! So i had a 11k combat points defeat with 2354 exp   and a game with the x3 bonus 14k combat points with 3600 exp .....where is the bonus?...Am i missing something ?

Clean #2 Posted 12 January 2018 - 07:16 PM

    Senior Master Sergeant

  • Advanced Member
  • 4407 battles
  • 147
  • [FIFO] FIFO
  • Member since:
    01-26-2012
The majority of games I get rewarded X1. One game I got X2. I think I have only got X3 once this evening. This game has more bugs than "I'm A Celebrity Get Me Out Of Here!".

Edited by Clean, 12 January 2018 - 07:16 PM.


britinmadrid #3 Posted 12 January 2018 - 07:22 PM

    Senior Master Sergeant

  • Advanced Member
  • 3937 battles
  • 111
  • [FIFO] FIFO
  • Member since:
    06-17-2012

Funny story: I was asked today to comment on whether or not I liked the service I had received for my Ticket to WoWp regarding Albion missions. I said no and politely explained why.

 

Now, I am experiencing the same problem as the two players above me. I am not receiving x3 XP for my games.

 

I won't bother with a ticket as I have to provide screen shots and replays which don't fit in the Ticket and which require me to reduce their size.

 

So, buggy game with sloooow customer service which requires me to spend hours re-formatting files to make a complaint. Armored Warfare failed and so will this game at this rate.



TheAlKey #4 Posted 12 January 2018 - 07:30 PM

    Airman Basic

  • Beta Tester
  • 1087 battles
  • 3
  • [BETA] BETA
  • Member since:
    01-26-2012

Same issues here with my FW 190 victory. Just earned the normal xp, even without the x2. Stopped playing after my first victory....



DreadArchangel #5 Posted 12 January 2018 - 07:56 PM

    Senior Airman

  • Member
  • 243 battles
  • 24
  • Member since:
    01-15-2013
Yeah def a bug, hopefully they'll sort it out, if their wanting to make this game a success and it could be, its a lot more playable now, and lots of fun, only been playing it for a week but really enjoying it. They'll have to make sure to keep in interesting tho, if they want to attract new players, but I'm enjoying it a big difference from what it was.:great:

vash_hu #6 Posted 12 January 2018 - 07:57 PM

    Airman Basic

  • Member
  • 731 battles
  • 2
  • [CI-CA] CI-CA
  • Member since:
    04-12-2011
I already opened a ticket at support because I also don't get the multipliers, I did not get it even yesterday when it was only x2. Is there anyone that gets the multipliers for first victory?

Eviscerador #7 Posted 12 January 2018 - 11:36 PM

    DAKKA!!! DAKKA!!! DAKKA!!!

  • Beta Tester
  • 2040 battles
  • 1,207
  • [BU-LL] BU-LL
  • Member since:
    01-26-2012
Same here, not getting the double and triple bonus since patch day. And we got a X3 weekend lol. Ah whatever, I expect at east a premium day as a reward, for each day we are losing our daily bonuses.

Tankitranki #8 Posted 13 January 2018 - 12:17 AM

    Master Sergeant

  • Advanced Member
  • 2661 battles
  • 74
  • [FEED] FEED
  • Member since:
    01-24-2013
The same here, open ticket but I doubt they answer and fix before Monday, too late as usual ... I hope I'm wrong but they will not give any compensation, will be our fault playing.
I like the game but it works really bad and without efficient  customer support ... not justified an expense for premium account or premium planes.

Mytola #9 Posted 13 January 2018 - 12:58 AM

    Airman Basic

  • Beta Tester
  • 550 battles
  • 4
  • [BBMM] BBMM
  • Member since:
    01-26-2012
Same here. Very annoying bug now that I have lots of planes to grind, and time to do it!

GoldKnight #10 Posted 13 January 2018 - 06:56 AM

    Senior Master Sergeant

  • Advanced Member
  • 3377 battles
  • 249
  • [FEED] FEED
  • Member since:
    10-14-2017
seems like they silently fixed it on restart, they work now, atleast on all planes i did try till now




7 user(s) are reading this topic

0 members, 7 guests, 0 anonymous users